Honda Silver Wing Scooter Forum

Hi, I am opening this site back up for new members. I closed it due to a few members complaining. Please just accept the site for what it is. The site is 'what it is'. We hope you enjoy the site. Please also join www.maxi-scoots.com !!!
 
HomeCalendarGalleryFAQSearchRegisterLog in
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» What did you do to your SW today.
by Easyrider Today at 9:44 pm

» front fork lower 600t v 600d
by Flyingpanman Today at 8:37 pm

» No ride but an interesting day never the less. The flying brush hog
by ItBeMe Today at 8:08 pm

» 2009 Silverwing 600 issue when driving
by Easyrider Today at 7:21 pm

» Silverwing 2012 ABS
by Jolly Bodger Today at 7:06 pm

» Engine drain bolt
by phils a winger Today at 5:15 pm

» Sat-Nav mount
by Dale N. Today at 11:25 am

» Added a new "Premium Package"
by Tn Traveler Today at 9:09 am

» Replacing clutch pads
by Jim Caudill Today at 12:23 am

» Greetings from east central Illinois ...
by JeffR Yesterday at 9:16 pm

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
free forum
 
Share | 
 

 Just saying Hi & checking in!

Go down 
AuthorMessage
gkh1255
Scooter Rider
Scooter Rider


Number of posts : 1
Location : Evansville, Indiana
Points : 311
Registration date : 2017-08-14

PostSubject: Just saying Hi & checking in!   Mon Aug 14, 2017 8:27 pm

My Honda silverwing brake lights don't work! not fuse, not bulbs. Running lights shine, but no difference when applying brakes! I checked wiring & connections around lights, & everything seems normal. I just bought this 2003 SILVERWING, and would appreciate your help. Thank you!
Back to top Go down
Cosmic_Jumper
Site Admin
avatar

Number of posts : 2674
Age : 75
Location : damn near Philadelphia, PA
Points : 6410
Registration date : 2009-06-12

PostSubject: Re: Just saying Hi & checking in!   Mon Aug 14, 2017 10:11 pm

Not much of an Introduction on your part, but did you try bypassing the brake light switches?
Back to top Go down
Dave Weller
Scooter Rider
Scooter Rider


Number of posts : 58
Location : Chatham Kent UK
Points : 2482
Registration date : 2011-11-09

PostSubject: Re: Just saying Hi & checking in!   Tue Aug 15, 2017 5:41 am

I was told that my brake lights did not work, both switches had failed, replaced and now all is fine again, also happened on my CBF600S, so Honda original switches do fail.
A simple fix, hope that's all it is, take switches off and test them with a multimeter set to ohms reading.
The Honda original ones are expensive, but check out ebay.
Back to top Go down
Easyrider
Silver Wing Expert
Silver Wing Expert
avatar

Number of posts : 553
Age : 67
Location : HI
Points : 1518
Registration date : 2015-12-18

PostSubject: Re: Just saying Hi & checking in!   Tue Aug 15, 2017 10:41 am

Try spraying electronic cleaners and working the switch. This may be the easiest way to fix your problem. WD40 is good if there is water in your switch. My 2cents.
Back to top Go down
 
Just saying Hi & checking in!
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Honda Silver Wing Scooter Forum :: Introductions-
Jump to: