Honda Silver Wing Scooter Forum

Hi, I am opening this site back up for new members. I closed it due to a few members complaining. Please just accept the site for what it is. The site is 'what it is'. We hope you enjoy the site. Please also join www.maxi-scoots.com
 
HomeCalendarGalleryFAQSearchRegisterLog in
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» 2010 silverwing low beam head LIGHT
by Ghost-rider Yesterday at 10:44 pm

» front brake light switch
by Dale N. Yesterday at 9:26 am

» Deno Introduction
by GHM-PM Wed Sep 19, 2018 8:09 am

» New ride to Hyder Alaska
by GHM-PM Wed Sep 19, 2018 8:06 am

» 2002 Reg/Rec location
by Cosmic_Jumper Tue Sep 18, 2018 11:41 pm

» Arizona Silver Wing/ scooter owners meet-up.
by GHM-PM Tue Sep 18, 2018 8:53 pm

» New(ish) Member
by Shaft Mon Sep 17, 2018 7:19 pm

» Tools for the road
by john grinsel Mon Sep 17, 2018 7:11 am

» Rear wheel spline wear
by Easyrider Sun Sep 16, 2018 12:29 am

» Slight oil leak
by Mech 1 twa Sat Sep 15, 2018 9:27 pm

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
free forum
 
Share | 
 

 GiVi Airflow windscreen - did I do it right?

Go down 
AuthorMessage
Gianfri
Scooter Rider
Scooter Rider


Number of posts : 10
Location : Kansas
Points : 588
Registration date : 2017-02-25

PostSubject: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 5:09 pm

Hello, I have installed the Airflow from GiVi on my 2012 SW. Everything went pretty well, thanks to the great directions found on this forum! However, after putting everything back together I noticed a small, but definitely visible gap between the cover and the windscreen on the dashboard side, where the first screw that we remove is. The picture is not very clear, but you can see the gap (this is looking at the dashboard from behind the windscreen, where the left screw is). The gap is on both sides. The mount feels really solid, and the screws are tight.
I was wondering if others have noticed that issue, or if you think I did something wrong? I can't imagine what that could be. Everything fits just right. The only thing is that I did not install the extra screw on the brackets (the one that goes on the short side of the bracket). I managed to drill the holes but in both cases I could not find any place ti thread the screw on. I left the bracket mounted with the other screws.
Any advice would be appreciated. Thanks!
Attachments
IMG_1786 crop2.jpg
You don't have permission to download attachments.
(65 Kb) Downloaded 32 times
Back to top Go down
Modernman1953
Touring Scooter Rider
Touring Scooter Rider


Number of posts : 377
Location : Yuma, AZ
Points : 1268
Registration date : 2016-06-01

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 8:24 pm

I didn't add the metal clips and extra screws either. Mine is doing fine.

Back to top Go down
Cosmic_Jumper
Site Admin
avatar

Number of posts : 2794
Age : 75
Location : damn near Philadelphia, PA
Points : 6633
Registration date : 2009-06-12

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 9:25 pm

Gianfri wrote:
Hello, I have installed the Airflow from GiVi on my 2012 SW. Everything went pretty well, thanks to the great directions found on this forum! However, after putting everything back together I noticed a small, but definitely visible gap between the cover and the windscreen on the dashboard side, where the first screw that we remove is. The picture is not very clear, but you can see the gap (this is looking at the dashboard from behind the windscreen, where the left screw is). The gap is on both sides.<>!

I have the same gap, and I have the brackets installed. HTH

Tim
Back to top Go down
Easyrider
Silver Wing Expert
Silver Wing Expert
avatar

Number of posts : 604
Age : 68
Location : HI
Points : 1664
Registration date : 2015-12-18

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 9:38 pm

I also have the same gap with the bracket installed with four screws on each side. I have tried to squeeze the parts together when tightening the screw, but the gap still exists.
Back to top Go down
Gianfri
Scooter Rider
Scooter Rider


Number of posts : 10
Location : Kansas
Points : 588
Registration date : 2017-02-25

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 9:44 pm

Well, I am relieved that those gaps are not the result of my mistake! And, although nobody stated that, I assume that (besides being ugly) they have not caused any problems, right?

Thanks!
Back to top Go down
Cosmic_Jumper
Site Admin
avatar

Number of posts : 2794
Age : 75
Location : damn near Philadelphia, PA
Points : 6633
Registration date : 2009-06-12

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Sun Apr 30, 2017 11:00 pm

As you stated, the picture isn't very clear, but I do have a similar gap.
Back to top Go down
Murf
Scooter Rider
Scooter Rider


Number of posts : 48
Location : NW Florida
Points : 572
Registration date : 2017-04-19

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Mon May 01, 2017 4:13 pm

I have a GIVI on my 04 Wing and it has that gap. No problems, No Worries
Back to top Go down
exavid
Silver Wing Guru
Silver Wing Guru
avatar

Number of posts : 2158
Age : 75
Location : Medford, Oregon
Points : 5625
Registration date : 2009-07-17

PostSubject: Re: GiVi Airflow windscreen - did I do it right?   Mon May 01, 2017 5:08 pm

I had to finagle the parts a bit to get that gap closed. I've installed both the Airflow and the adjustable windshields on Silverwings. I didn't get much if any gap with the adjustable but my friend's Airflow screen did have pretty noticeable gaps. It turned out that the two outer screws behind the windshield hadn't fully engaged the nut plates and weren't pulling up snugly.
Back to top Go down
 
GiVi Airflow windscreen - did I do it right?
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Honda Silver Wing Scooter Forum :: Honda Silver Wing :: Accessories & Modifications-
Jump to: