Honda Silver Wing Scooter Forum

Welcome to the home for Honda SilverWing and everyone interested. This is a place to ask questions, share, and learn about the SilverWing and its dedicated riders. Please post an introduction when you join as a sign of Courtesy.
 
HomeCalendarGalleryFAQSearchRegisterLog in
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» 25g Dr Pulley sliders fitted.
by bill tucker Today at 18:57

» Dr Pulley sliders
by MadDog Today at 17:28

» Did I change last scooter tire today??
by bill tucker Today at 14:11

» Introduction
by Scooter Bob Today at 12:45

» For sale 2013 silver wing
by cliffyk Yesterday at 21:17

» Looking to DS my 2004 Swing Trike
by DickO Yesterday at 18:55

» Belt Slapping
by Pastor Ron Yesterday at 17:24

» Final face squeal
by oldwingguy Yesterday at 16:22

» Just saying Hi & checking in!
by Easyrider Yesterday at 10:41

» happy with new tire combination
by pgnz Yesterday at 01:52

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
free forum
 
Share | 
 

 Top box not latching problem

View previous topic View next topic Go down 
AuthorMessage
gilesmdavis
Scooter Rider
Scooter Rider


Number of posts : 40
Location : South Wales (UK not Australia)
Points : 1132
Registration date : 2014-09-12

PostSubject: Top box not latching problem   Sun 03 May 2015, 18:43

I am having a problem with my Kappa top box.

I've installed a new Givi Plate - all fairly straightforward. I connected my old Kappa / Givi box, locked it and felt rather clever.

As the bike dropped off the centre stand the nominal jolt disconnected the box. Hmmmm, not right.

I had a few goes at reattaching. The key doesn't seem to be locking the box on to the plate connector. I've never had this problem with the box before. Anyone experienced this?

I hope it might be the rubber studs on the rack are keeping it too proud but it did sound like it was connecting.

I'll have another go in the morning but any ideas welcome.

Thanks

Giles
Back to top Go down
Meldrew
Silver Wing Guru
Silver Wing Guru
avatar

Number of posts : 2630
Location : York, North Yorkshire, England UK
Points : 5147
Registration date : 2010-11-16

PostSubject: Re: Top box not latching problem   Sun 03 May 2015, 20:04

A common problem is trying to fit Givi/Kappa Monokey top boxes to Givi/Kappa Monolock rear racks and vice-versa.
Back to top Go down
GHM-PM
Site Admin
avatar

Number of posts : 1192
Age : 64
Location : Wickenburg, AZ
Points : 3223
Registration date : 2012-05-17

PostSubject: Re: Top box not latching problem   Sun 03 May 2015, 22:32

Meldrew wrote:
A common problem is trying to fit Givi/Kappa Monokey top boxes to Givi/Kappa Monolock rear racks and vice-versa.

This seems strange for as much positive feedback for all things Givi on here. Or am I missing something?
Back to top Go down
gilesmdavis
Scooter Rider
Scooter Rider


Number of posts : 40
Location : South Wales (UK not Australia)
Points : 1132
Registration date : 2014-09-12

PostSubject: Re: Top box not latching problem   Mon 04 May 2015, 02:59

Annoyingly I had the Givi plate on my old Deauville and it worked fine. Alas it's still attached. I'll have a tinker this morning. Worst case (no pun intended) I'll drill through it and bolt it on. I'll report back
Back to top Go down
john grinsel
Silver Wing Guru
Silver Wing Guru


Number of posts : 2128
Points : 5431
Registration date : 2009-08-18

PostSubject: Re: Top box not latching problem   Tue 05 May 2015, 11:43

Based on 500,000 miles with my 1998 Givi E-46 box on various bikes GIVI on Givi racks or grids=works and is safe and secure. why screw around? Bolting directly should work also.
Back to top Go down
gilesmdavis
Scooter Rider
Scooter Rider


Number of posts : 40
Location : South Wales (UK not Australia)
Points : 1132
Registration date : 2014-09-12

PostSubject: Re: Top box not latching problem   Tue 05 May 2015, 12:07

Hah, I solved it.
The Kappa latch has a notch in the middle, I Dremeled out the lip of the Givi plate and it held secure.

After a really unpleasant journey this morning (very wet, very windy, lost rear end traction on motorway on-ramp leading to heart-stopping wobble (but all right)) I can confirm that the box is very secure.

I'll get onto the Givi screen later...
Back to top Go down
 
Top box not latching problem
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Top box not latching problem
» Trunk Lid Release Problem
» K100 starting problem
» Rear Hatch Problem
» Electronic distributor install problem

Permissions in this forum:You cannot reply to topics in this forum
Honda Silver Wing Scooter Forum :: Honda Silver Wing :: Accessories & Modifications-
Jump to: